A PHP Error was encountered

Severity: 8192

Message: mysql_escape_string(): This function is deprecated; use mysql_real_escape_string() instead.

Filename: mysql/mysql_driver.php

Line Number: 303

Часто задаваемые вопросы по Joomla 1.7. (Joomla 1.7 FAQ)

Часто задаваемые вопросы по Joomla 1.7. (Joomla 1.7 FAQ)

Автор: Mowshon.
Опубликовано 5 августа 2011
в рубрике Joomla, Самоучитель
и помечено как: , .

Просмотров: 9584.
Подписаться на комментарии по RSS.

Часто задаваемые вопросы по Joomla 1.7. (Joomla 1.7 FAQ)

Как только состоялось официальное представление Joomla 1.7, у всех, кто является приверженцами и фанатами этой CMS возникло множество самых разнообразных вопросов, на которые мы и решили ответить в рамках этой статьи, названной нами «FAQ по Joomla 1.7».

1. Нужно ли обязательное обновление сайта с версии Joomla 1.6 до версии Joomla 1.7?

Это просто необходимо, так как уже известно (и об этом было заявлено на самом официальном уровне), что Joomla 1.6 перестанет существовать, если уже не перестала, в самое ближайшее время. А это означает только одно: что хоть такие сайты и будут существовать, обновления под них вы уже не найдете, что влечет за собой ту же проблему невозможности восстановления после взлома и прочих атак и сбоев.

Отсюда и вывод – пока есть время, переходим на Joomla 1.7, и делаем это как можно быстрее.

2. А что, если я не обновлю свой сайт до Joomla 1.7?

В принципе, ничего страшного не случиться. Кроме одного – из Интернета постепенно исчезнут все плагины и расширения для старых версий Joomla. А кроме того с каждым днем ваш сайт будет устаревать, как внешне, так и технически. Все пойдут вперед, используя те возможности, которые предоставляет веб-мастерам Joomla 1.7, а вы будете плестись в конце. Вас это устраивает? Тогда милости просим... в прошлое Интернета.

3. Как обновить свой сайт до Joomla 1.7?

Во-первых, подобное обновление возможно только для сайтов, созданных с использованием Joomla 1.6.5 и выше, только тогда вы сможете без проблем вы сможете обновить свой сайт до Joomla 1.7. Если же нет, то придется начинать все с начала – удалять сайт с сервера, заливать его заново, и заново наполнять контентом.

4. Совместимы ли шаблоны и гаджеты Joomla 1.6 с Joomla 1.7?

По заявлению разработчиков – да, и мало того, программисты Joomla гарантируют, что работать они будут без сбоев и глюков. Однако опыт прошлых обновлений Joomla говорит о необходимости создания резервной копии сайта; тестирования его работы после обновления; проверить правильность работы всех расширений.

5. Чем отличается Joomla 1.7 от более старых версий?

Самое интересное, что глобальных обновлений не так много:

1. Теперь вы сможете добавлять фоновые рисунки в модуле «Пользовательский XTML»;

2. Появилась кнопка «Удалить папку установки»;

3. Возможность добавления имени сайта до или после заголовка страницы.

Главное другое – в новой версии удалено более 300 ошибок, которые так мешали всем тем, кто привык работать с CMS Joomla.

6. А что будет с сайтами, построенными с Joomla 1.5?

Они устареют, так как поддерживаться версия Joomla 1.5 будет лишь до 01.04.2012. И произойдет это хотя бы потому, что уже в январе следующего года нам будет представлена Joomla 1.8.

7. Так что делать сегодня?

Если есть возможность, то обновлять свой сайт Joomla 1.7, что избавит вас от дальнейших проблем при выходе Joomla 1.8 и следующих обновленных версий. Хотя с другой стороны – все расширения для этих версий будут не просто платными, а стоить немалых денег, в то время как плагины и компоненты для Joomla 1.5 станут окончательно бесплатными... Вот и решайте, что для вас важнее – соответствовать веяньям веб-моды или экономия.

Комментариев: 3

  1. Leo | 22.02.2012 в 12:15:06 | #1

    Может быть мне кто-нибудь подскажет как совместить джуумлу 1.7.30 с Дримвивером? Хочеться редактировать страницы именно через этот редактор. У меня Джуумла стоит на локальном сервере appserv, в папке www создана папка sait1 с джуумлой. И если браузер открывает страницы джуумлы, то Дримвимвер ни в какаую не желает обрабатывать PHP страницы, выдаёт что возникла ошибка при обработке динамических файлов, то пишет что указанный сервер не найден. Может я неправильно прописал сервер в Дримвивере, или нужно как-то особенно настроить сам аppserv?

  2. Mowshon | 24.02.2012 в 17:30:00 | #2

    Leo, если Вы работаете с Joomla на локальном компьютере(127.0.0.1) тогда зачем создавать с ним подключения?

    Открывайте локальные файлы(Ctrl+O) через этот редактор путем указания полного адреса до него. Работая на локальном компьютере с сайтами нет необходимости создавать с ними FTP-подключение через Dreamwaver, чтобы открыть файлы.

  3. Leo | 25.02.2012 в 19:18:24 | #3

    Так в том то и дело, что никакие PHP файлы в дримвивере не открываются, каким бы способом их не пытался открыть. Дримвивер выдаёт инфу что не может обработать динамические страницы, а для этого требует прописать в настройках тестовый сервер.

Оставьте комментарий!

Гость
Комментатор / хотите им стать

Чтобы стать комментатором введите email и пароль. Напишите комментарий. В дальшейшем ваша связка email-пароль, позволит вам комментировать и редактировать свои данные. Не забудьте про активацию (инструкция придет на ящик, указанный при регистрации).

grin LOL cheese smile wink smirk rolleyes confused surprised big surprise tongue laugh tongue rolleye tongue wink raspberry blank stare long face ohh grrr gulp oh oh downer red face sick shut eye hmmm mad angry zipper kiss shock cool smile cool smirk cool grin cool hmm cool mad cool cheese vampire snake excaim question

(обязательно)